CRF450L : PowerCommander + AutoTune + O2 sensor delete?!
  • erwanc
    Posts: 1
    Joined: Wed Jan 15, 2020 3:08 am

    CRF450L : PowerCommander + AutoTune + O2 sensor delete?!

    by erwanc » Wed Jan 15, 2020 3:16 am

    Hi everyone,

    I installed a Yoshimura full exhaust system, a Dynojet PowerCommander and a Dynojet AutoTune on my Honda 2019 CRF450L.

    This is the international model which has an O2 sensor. When installing the AutoTune, I removed the original sensor, disconnected it from the harness and installed the new one that goes into the AutoTune module.

    The problem is, I now have a check engine light. A quick fix would be to plug in an O2 eliminator in the harness and let the PCV + AutoTune do the magic, but I can't find an eliminator kit for the CRF450L and Dynojet now tells me I should run both sensors, which seems ludicrous. I understand they're being sued by California because their products challenges emission legislation.

    This is not practical and I need a way to trick the stock ECU to turn off the check engine light. I just tried a DIY method soldering a 2.2k ohm resistor at the end of the stock O2 sensor connector but it hasn't yielded success yet.

    Does anybody know of an eliminator that uses the CRF450L O2 sensor connect pictured here? https://ibb.co/xL063bR

    Any help is appreciated. At this point I'm getting a bit desperate and considering just getting a Vortex ECU by Tokyomods. Thank you!
  • User avatar
    JimDirt
    Posts: 3855
    Joined: Sat Nov 25, 2006 6:31 pm

    Re: CRF450L : PowerCommander + AutoTune + O2 sensor delete?!

    by JimDirt » Wed Jan 15, 2020 12:54 pm

    Welcome to the site !! \:D/

    What I am wondering , is if the O2 sensor is giving a heat set reading , in other words , the resistance is not registered all the time (which you are trying to duplicate using the resistor) , but when the O2 sensor reaches a certain temp and then opens and then sends the signal , like a electronic thermostat for a electric fan would be , which is confusing the ECU because it is reading all the time , I guess the only confirmation to that would be to leave the sensor out , plugging the hole and just plugging it in at the connector and have it pulled up out of the way not near a heat source , if it keeps the light out , then that means the sensor is not heat activated , if it does , then they may be correct and you need to have them both plugged in ...... which to me would mean you would need a second bung in the header to make their as well as the OEM sensors read correctly .....

    What does Dynojet suggest is the correct parts to use to do the dual setup ??? , do they have the parts ?? , part numbers ?? , and if so why was it not included in the kit ??? , I would certainly get back with them and ask these questions , as I would think if they are selling this kit , they would have the resources to either supply all necessary hardware required to do the install correctly and completely , with it , or provide a source , along with part number's , for you to buy the needed parts to make their partial kit work/function properly ...... So I would recommend contacting them again , and demanding a resolution (calmly of course) of either the parts to complete the instal , or the resource to get them , and to update their description of the kit , to inform the customer prior to sale that other parts are needed or that they omitted the parts to make you buy them from them at a extra charge , which would be a poor way to conduct business if that were the case , since they must know that installing their kit would set off a warning light , so you would think they would have a resolution for that very issue ..... :-k
    2020 CRF450R
    02 CRF450R
    2006 CRF450X
    Image
    Weiser , Idaho

Who is online

Users browsing this forum: No registered users and 0 guests